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SCRUM ALLIANCE CERTIFICATION

Scrum Alliance Certifications are the perfect way 
to get the skills you need to advance your career 
and transform the world of work: 

Certified ScrumMaster
Advanced Certified ScrumMaster
Certified Scrum Product Owner
Advanced Certified Scrum Product Owner  
Certified Agile Facilitator

SCRUM ALLIANCE MICRO-CREDENTIALS

Scrum Alliance Micro-Credentials are a great 
way to engage and gain Agile knowledge: 

Agile OKR's
Agile In Sales
Agile Essentials
Scrum Essentials
AI For Scrum Masters
AI For Product Owners
Get Started With AI Prompt Engineering 
Introduction To Agile Coaching
Becoming An Agile Coach
Agile Coaching Skills
Conflict Management Skills

TEAM IMMERSION WORKSHOP

This private workshop offers participants a hands-
on opportunity to experience the entire Agile 
lifecycle in a condensed format, using their actual 
work. From crafting a vision to executing daily 
activities, all aspects of Agile planning are 
addressed. Participants will learn, practice, and 
master prioritization and estimation techniques as 
a team. Key Agile principles, including cadence, 
communication, and transparency, are emphasized 
and internalized through collaborative learning. By 
immersing themselves in this shared experience, 
teams can accelerate their journey to Agile success 
and achieve outstanding results.

AGILE LEADERSHIP SUMMIT

The success of Agile implementations depends heavily 
on the support and trust of executive leadership and 
management. Executives play a vital role in removing 
obstacles, empowering teams, and inspiring the 
organization to better serve its end consumers. 
Achieving these outcomes requires a shared 
understanding between executives and teams. This 
summit serves as a forum to build a solid foundation 
of Agile knowledge, both in principle and practice. 
Participants will gain insights into setting realistic 
expectations and learn effective strategies to support 
Agile teams and processes, driving organizational 
success.
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AGILEDAD CREDENTIALED COURSES

These courses are designed to maximize the value 
of your learning experience, focusing on actionable 
skills and real-world application. Whether you aim 
to enhance team performance, improve leadership 
abilities, or deepen your Agile knowledge, these 
award-winning classes provide everything you need 
to succeed without the pressure of certification 
requirements.

Agile and Scrum Fundamentals
Advancing and Scaling Agile
AI For Project Managers
AI For Product Managers
AI Application For Leaders
AI Application In Agile
Agile Leadership Summit (Levels 1-3) 

AI COURSE OFFERINGS

AI isn’t the future it’s already changing how teams 
plan, lead, and deliver. AgileDad’s AI courses are 
designed for real practitioners who want practical, 
immediately usable skills, not theory or buzzwords. 
Our AI offerings show leaders, ScrumMasters, 
Product Owners, and teams how to leverage AI 
responsibly to improve decision-making, accelerate 
delivery, enhance facilitation, and reduce waste all 
while keeping people at the center of the work. No 
fluff. No fear-mongering. Just pragmatic AI for 
modern Agile teams.
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Overview

EMPOWERING AGILE TEAMS

The transition from traditional project management 
to a lean Agile approach can be challenging for 
many teams. Adapting to being self-organized, self-
managed, and fully empowered often requires a 
significant shift in mindset and practices. This session 
is designed to help teams navigate the 
organizational transformation that accompanies a 
full transition to Agile. Participants will gain a deeper 
understanding of what to expect, how to embrace 
empowerment, and how to thrive in an Agile 
environment.

PMI CERTIFICATION PREP

We are proud to offer comprehensive 
preparatory sessions for the following PMI-
accredited certifications:

PMI-ACP Test Certification Prep
PMP Test Certification Prep
PMI-PBA Certification Test Prep

Each session is designed to ensure your 
success, providing all necessary materials and 
books. These workshops include a pre-test to 
assess readiness, interactive sessions to 
deepen understanding, and practical 
strategies to help you achieve certification 
with confidence.

Agile Coaching & Mentoring

AgileDad coaches are globally recognized as 
industry leaders, known for their 
hands-on approach in helping 
organizations make critical decisions and 
empowering teams to thrive in their Agile 
journey. 

We stand behind our services with a 100% 
satisfaction guarantee. Coaching is offered 
in flexible buckets of hours that can be used 
as needed, at any level, and never expire. 

For more information, contact  
LearnMore@AgileDad.Com and discover 
how AgileDad coaching can drive your 
success.

All AgileDad training workshops are available in two formats public sessions with a diverse group of students 
or private sessions tailored exclusively for your team. Workshops can be conducted virtually via Zoom or 
delivered live on-site at your company, offering flexibility to meet your specific needs.

AgileDad specializes in creating custom training curriculum tailored to your organizations unique needs. 
These custom programs can be purchased outright or licensed for ongoing use, ensuring your teams receive 
the most relevant and impactful training to drive success.

AgileDad coaches have provided training and coaching at 45 of the Fortune 100 companies, demonstrating 
our proven expertise in driving Agile success. Additionally, our Agile Project Management curriculum is taught 
at many major universities, equipping the next generation of professionals with the skills needed to excel in 
today's dynamic business environment.
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Why 
AgileDad?

About AgileDad: 
At AgileDad, we stand apart as a global leader in Agile certification training and business agility coaching. Our approach is inclusive, pragmatic, and deeply rooted in 
human psychology. Unlike traditional frameworks, we provide actionable tools and strategies tailored to thrive in today's ever-evolving business environment. With 
the rise of remote work and innovative collaboration methods, AgileDad is at the forefront, delivering leadership guidance and customized solutions to help 
organizations achieve true business agility.

We believe agility is not a one-size-fits-all solution. AgileDad embraces a philosophy centered on collaboration and communication, recognizing that every 
organization has unique needs and structures. Instead of applying a cookie-cutter approach, we work with you to design an Agile process that aligns seamlessly with 
your business operations, ensuring more frequent and reliable delivery cadences.

Organizational change requires time, expertise, and skilled guidance. Without it, efforts to adopt Agile can be costly and ineffective. Our mission is to empower your 
team, enabling you to establish an internal Agile Center of Excellence. This foundation provides the tools, knowledge, and confidence for a successful Agile 
transformation. Ultimately, our goal is to make our guidance redundant as your organization becomes self-sufficient in Agile practices.

895 218
AgileDad has hosted over 800 
Public CSM & CSPO workshops.

45

218 Public 
Recommendations on 
AgileDad LinkedIn Profile

99%
AgileDad has provided 
Coaching & Training in 45 of 
the Fortune 100 Companies

99% of AgileDad Students 
pass their certification exam 
after attending a workshop.
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AGILEDAD SNAPSHOT

REGISTERED EDUCATION PROVIDER

12,458
AgileDad has certified 

over ten thousand 
ScrumMasters 

through the Scrum 
Alliance

10%
10% of all AgileDad 

earnings are donated 
to local, national, & 
international charity 

organizations

4,992
AgileDad has 

certified over four 
thousand Product 

Owners through the 
Scrum Alliance

28
AgileDad offers 

twenty-eight Agile 
Training workshops 
in addition to our 

world class coaching 
offerings! 

4,984
Agile teams have 

received Agile Coaching 
from AgileDad

24
AgileDad was founded in 

2002. This means we 
have over 24 years of 
Agile Experience to 

share with your 
organization

AgileDad has been recognized as a world class 
training & education provider and has been 
approved by every major accreditation body. 



University - College Brochure    l    Page  10

CO
U

RS
ES

 &
 W

O
RK

SH
O

PS

AgileDad - Course Offerings   l    Page 6 



About The Agile Fundamentals Workshop

One of the most common points of Agile adoption 
failure comes with the incremental on-boarding of 
Agile teams throughout an organization while not 
having everyone starting with the same foundational 
Agile knowledge. This workshop session is designed 
to help everyone on the team learn the fundamental 
principles behind what makes Agile work, and allows 
them to participate in several real world exercises. 
This structure allows everyone on the team to learn 
the ‘Why’ behind the ‘How’, and gives everyone a 
chance to leave with the tools needed to effectively 
do their job better. This is a mandatory prerequisite 
to any Advanced or Scaling Agile training session.

 Class Logistics: 

〉AgileDad Credentialed Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Qualify For Advanced Workshop

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Agile Principles & Values 

> Defining Agile
> Agile Manifesto & 12 Principles
> The Agile Landscape
> Agile vs. Waterfall
> The Scrum Flow Disconnect

10:15 – 12:00 PM Roles & Accountabilities

> Roles Overview
> Agile Leadership
> The POBAFATA Defined
> ScrumMaster Defined
> Self Organized Teams

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Planning & Process

> The Agile Meetings Playbook
> Vision & Strategy
> ART Of The Agile Press Release
> Roadmap Planning
> Defining The Backlog
> Understanding Personas

2:30 – 3:00 PM 
Backlog Item Creation, 
Prioritization, and Estimation

> Priority Defined
> Complexity Defined
> MoSCoW Defined
> Objective Stack Ranking

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Rapid Release Planning 

> Release Defined
> Release Planning Strategy
> Value of Release Planning
> RRP Detailed Instructions
> The Sliding Scale

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Sprint Planning 
& Daily Meeting 

> Definition of Done
> Sprint Planning Details
> Daily Meeting Rules
> Working With Remote Teams
> Agile Reporting

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Review, Demo, 
& Retrospective 

> Sprint Review
> Sprint Demo
> Sprint Retrospectives
> Importance of Limiting WIP
> Dealing With Interruptions
> Podcast & Other Resources

3:30 – 5:00 PM Course Closure 
> Backlog Refinement
> Understanding Communication
> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile & Scrum Fundamentals
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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About Advancing & Scaling Agile Workshop Many 
Teams and Organizations have been practicing Agile 
for quite some time. and have mastered all of the 
foundational principles. This workshop is specifically 
designed to explore and discuss advanced Agile 
concepts. We will answer the how and why behind 
many Agile techniques and introduce you to the parts 
of Agile that are not discussed in best-selling books or 
industry leading videos. 

We will also explore an agnostic view towards scaling 
business agility. Learn what works and where you 
may need to steer clear. The end goal is to focus on 
what is needed in order to create an internal Agile 
Center of Excellence. 

Many have dubbed this workshop Agile 2.0.

 Class Logistics: 

〉AgileDad Credentialed Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Agile Coaching

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Full Agile Landscape 

> Defining Full Agile
> Breakdown of Initiate
> Deconstructing Discovery
> Delivery Execution
> Planning For Release

10:15 – 12:00 PM 
Advancing Roles 
& Accountabilities

> Leadership Engagement
> Breaking Down the POBAFATA
> Roles vs. Titles - Who Cares
> ScrumMaster Magnified
> The Agile Center of Excellence

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Managing Technical Debt 
and Interruptions

> What is Technical Debt
> Unintentional vs Intentional Debt
> Seven Debts Deep Dive
> Known But Not Resolved
> The Technical Debt Sprint
> The Cost of Interruptions

2:30 – 3:00 PM The Team John Concept
> Laser Focus vs High Performance
> Team John Applied
> Measurable Results
> When NOT To Team John

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Rapid Release Planning 

> Release Defined
> Release Planning Strategy
> Value of Release Planning
> RRP Detailed Instructions
> The Sliding Scale

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Objective Stack Ranking

> Priority Equals Urgency
> Advanced Story Pointing Techniques
> Time vs Relative Complexity
> OSR Applied
> Understanding The Formula

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Scaling Demystified 

> Scaling Techniques
> SAFe Essentials
> LeSS Is More
> Scrum At Scale
> Disciplined Agile Delivery
> When NOT to Scale

3:30 – 5:00 PM Course Closure 
> Backlog Review
> Podcast & Additional Resources
> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advancing & Scaling Agile
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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AI For Project Managers 

Project Managers balance scope, timelines, risk, cost, 
and people in an environment of constant change. As 
AI becomes part of daily work, Project Managers 
must know how to use it responsibly to support 
planning, decision-making, and delivery without 
losing the human side of leadership.

This workshop focuses on practical, real-world 
applications of AI for Project Management from 
smarter planning and risk awareness to clearer 
reporting and decision support. AI isn’t replacing 
judgment; it’s augmenting it.

Grounded in years of hands-on Agile coaching and 
delivery experience, this workshop goes beyond 
frameworks and textbooks and goes straight into the 
LLM to help you engage and use AI to better execute 
in your work responsibilities.

 Class Logistics: 

〉AgileDad Credentialed Course
〉1 Day Online or In-Person Workshop 
〉Class Eligible For 8 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for AI Appliation In Agile

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 9:30 AM The Reality of AI In 
Project Management

> Current AI Capabilities
> Common AI Myths
> Agile and Hybrid Fit
> Automation vs Intelligence
> Organizational AI Maturity

9:30 – 10:00 AM AI As An Augmentation Tool

> Preserving Accountability
> Human Judgement Priority
> Avoiding Decision Abdication
> Leadership Effectiveness Boost
> Clarity Over Control

10:00 – 10:15 AM Morning Break

10:15 – 10:45 AM 
Responsible AI Use For 
Project Managers

> Ethical Considerations 
> Data Bias Risks
> Information Security
> Stakeholder Transparency
> Usage Guardrails
> Real Working Examples

10:45 – 11:15 AM 
AI Enhanced Planning 
& Forecasting

> Scenario Modeling
> Pattern Recognition
> Estimation Support
> Team-based Planning

11:15 – 11:45 AM AI For Risk Identification 
& Issue Detection

> Early Warning Signals
> Trend Analysis
> Proactive Mitigation

11:45 – 12:00 PM Pre-Lunch Recap 
> Pre-Lunch Review
> Open Q&A 

Lunch

1:00 - 1:30 PM Smarter Reporting & 
Executive Communication

> Data Synthesis
> Executive Translation
> Automated Updates
> Metric Integrity
> Trust Building

1:30 – 2:00 PM AI in Facilitation & Collaboration 

> Agenda Preparation
> Retrospective Support
> Stakeholder Alignment
> Meeting Effectiveness
> Human Centered Collaboration

2:00 – 2:30 PM Afternoon Break

2:30 – 3:30 PM Building an AI-Aware Project 
Management Practice

> Role Evolution
> Skill Development
> Sustainable Habits
> Value Measurement
> Change Leadership
> Effective Prompting

3:30 – 5:00 PM Course Closure 

> Information Summarization Workflow 
Integration

> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

AI  For Project Managers
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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AI For Product Managers 

Product Managers operate at the intersection of 
customer value, business strategy, and delivery 
reality. As AI becomes embedded in modern 
products and organizations, Product Managers must 
learn how to use AI responsibly to improve discovery, 
prioritization, strategy, and communication, without 
outsourcing product thinking or customer empathy.

This workshop focuses on practical, real-world AI 
applications that help Product Managers make better 
decisions, create clearer roadmaps, and deliver 
meaningful outcomes, while keeping humans firmly 
at the center.

Grounded in years of hands-on Agile coaching and 
delivery experience, this workshop goes beyond 
frameworks and textbooks and goes straight into the 
LLM to help you engage and use AI to better execute 
in your work responsibilities.

 Class Logistics: 

〉AgileDad Credentialed Course
〉1 Day Online or In-Person Workshop 
〉Class Eligible For 8 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for AI Appliation In Agile

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 9:30 AM 
The Reality of AI In 
Product Management

> AI Capability Realities
> Product AI Myths
> Opportunity Identification
> Product AI Fit
> Maturity Assessment

9:30 – 10:00 AM AI As Product Decision Support

> Judgment First
> Augmented Insights
> Automation Bias Risks
> Decision Accountability
> Clarity Over Certainty

10:00 – 10:15 AM Morning Break

10:15 – 10:45 AM 
Responsible And 
Ethical AI Products

> Ethical Product Design
> Bias Awareness
> Data Responsibility
> Stakeholder Transparency
> Customer Trust
> Transparency Expectations

10:45 – 11:15 AM 
AI In Product 
Discovery & Learning

> Insight Synthesis
> Pattern Recognition
> Hypothesis Generation
> Discovery Acceleration

11:15 – 11:45 AM AI Assisted Prioritization 
and Tradeoffs

> Outcome Focus
> Tradeoff Clarity
> Noise Reduction

11:45 – 12:00 PM Pre-Lunch Recap 
> Pre-Lunch Review
> Open Q&A 

Lunch

1:00 - 1:30 PM Strategy, Roadmaps, 
and Outcomes

> Strategic Alignment
> Scenario Planning
> Outcome Roadmapping
> Portfolio Visibility
> Strategic Storytelling

1:30 – 2:00 PM 
Communicating With 
Stakeholders Using AI

> Executive Narratives
> Decision Framing
> Expectation Alignment
> Facilitation Support
> Trust Reinforcsment

2:00 – 2:30 PM Afternoon Break

2:30 – 3:30 PM Building an AI-Enabled 
Product Practice

> Role Evolution
> Skill Development
> Sustainable Adoption
> Outcome Measurement
> Product Leadership
> Effective Prompting

3:30 – 5:00 PM Course Closure 

> Information Summarization 
Workflow Integration

> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

AI  For Product Managers
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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AI Application for Leaders 

Leaders today are navigating unprecedented 
complexity, rapid change, increasing expectations, 
and accelerating technology. AI is now part of that 
reality. Leaders don’t need to become technologists, 
but they must understand how to apply AI 
responsibly to improve clarity, decision-making, 
communication, and outcomes without eroding trust, 
culture, or accountability.

This workshop focuses on practical, real-world 
applications of AI for leaders who want to lead with 
confidence, wisdom, and humanity in an AI-enabled 
world.

Grounded in years of hands-on Agile coaching and 
delivery experience, this workshop goes beyond 
frameworks and textbooks and goes straight into the 
LLM to help you engage and use AI to better execute 
in your work responsibilities.

 Class Logistics: 

〉AgileDad Credentialed Course
〉1 Day Online or In-Person Workshop 
〉Class Eligible For 8 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for AI Appliation In Agile

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 9:30 AM The Reality of AI For 
Modern Leaders

> AI Capability Realities
> Leadership AI Myths
> Opportunity Awareness
> Business Impact Areas
> Organizational Readiness

9:30 – 10:00 AM 
AI As Leadership 
Decision Support

> Judgment Remains Human
> Augmented Insights
> Avoiding Automation Bias
> Decision Accountability
> Clarity Over Certainty

10:00 – 10:15 AM Morning Break

10:15 – 10:45 AM 
Responsible And Ethical 
Leadership With AI

> Ethical Considerations 
> Bias Awareness
> Data Responsibility
> Trust Preservation
> Usage Guardrails
> Leadership Guardrails

10:45 – 11:15 AM 
AI In Strategy And 
Direction Setting

> Scenario Exploration
> Strategic Assumptions
> Pattern Recognition
> Risk Visibility

11:15 – 11:45 AM AI For Communication 
And Influence

> Message Clarity
> Executive Storytelling
> Stakeholder Alignment

11:45 – 12:00 PM Pre-Lunch Recap 
> Pre-Lunch Review
> Open Q&A 

Lunch

1:00 - 1:30 PM AI Supporting Teams 
And Culture

> Workload Visibility
> Team Health Signals
> Psychological Safety
> Change Support
> Human-Centered Leadership

1:30 – 2:00 PM Knowing When NOT To Use AI

> High-stakes Decisions
> Empathy Required
> Ethical Boundaries
> Overconfidence Risks
> Human Judgment Moments

2:00 – 2:30 PM Afternoon Break

2:30 – 3:30 PM Building an AI-Aware 
Leadership Practice

> Leadership Role Evolution
> Skill Development
> Sustainable Adoption
> Outcome Measurement
> Leading Responsibly
> Effective Prompting

3:30 – 5:00 PM Course Closure 

> Information Summarization 
Workflow Integration

> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

AI  Application For Leaders
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 

AgileDad - Course Offerings   l    Page  11



About AI Application In Agile

This one-day AgileDad Credentialed Workshop 
is designed to introduce participants to the 
transformative capabilities of AI as they apply to 
Agile practices, enhancing project management, 
team dynamics, and delivery outcomes.

During this dynamic session, you will dive deep 
into the fundamentals and applications of 
leading AI technologies such as Claude, Gemini, 
Jasper, CoPilot, and notably, ChatGPT-5x. These 
tools are at the forefront of AI innovation, 
offering unique solutions that can streamline 
decision-making processes, automate routine 
tasks, and provide insightful analytics, thereby 
accelerating the Agile workflow and increasing 
project efficiency.

Whether you are a product owner, a scrum 
master, or a team member seeking to 
leverage AI within your Agile environment, 
this workshop will equip you with the 
knowledge and skills needed to effectively 
integrate AI tools into your daily operations. 
V. Lee Henson's expert guidance ensures a 
comprehensive learning experience, with 
practical examples and interactive 
discussions that highlight how AI can solve 
real-world problems in Agile settings.

Harness the power of AI and revolutionize 
your Agile practices. Gain the insights and 
tools necessary to lead your projects and 
teams towards more innovative and 
productive horizons.

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 9:40 AM Generative AI Foundations

> Understand Essential Terms
> Explore Various AI Models
> Prompt Writing Explained
> Ethical AI Explained
> Agile & AI Synergy

9:40 – 10:15 AM
AI Product Idea Generation 
and Brainstorming

> AI Generated Product Ideas
> Brainstorming & Communication
> High Level Project Plan Creation
> Key Agile Roles Defined
> API Tool Integrations

10:15 – 10:30 AM

10:30 – 11:00 AM Vision & Strategy Creation

> The Agile Press Release
> The Elevator Pitch
> North Star vs Product Vision
> Product Brand Awareness
> The Question Words
> Help Me Understand

11:00 – 11:15 AM Visual & Contextual 
Roadmapping

> Epic Level Roadmapping 
> Swim-Lane Roadmaps by Quarter
> Contextual Roadmaps
> Visual Roadmapping

11:15 – 11:30 AM Sample Product 
Backlog Creation

> Feature & Story Introduction
> Breaking Down Complex Work
> Backlog Creation & Allocation

11:30 – 12:00 PM Create a Perfect Persona > Persona Identification & Creation
> Visual Empathy Mapping

1:00– 2:15 PM Build Amazing Team 
Working Agreements

> Workplace Culture, Norms, & Standards
> Meeting Templates & Guidelines
> Team Working Agreement Creation
> Communication Styles & Preferences
> Team Sign-Off

2:15 – 2:30 PM Afternoon Break 

2:30 – 3:45 PM Exporting Assets From AI

> Prompts To Export Assets
> Perfecting Export Results
> Validate and Verify Data
> AI Memory Building
> Create A Prompt Library

3:45 – 4:00 PM Afternoon Break 

4:00 – 4:30 PM 
Generating Meaningful 
AI Prompts

> Create a Prompt to Master Prompt
> Teach AI To Ask You FIRST
> Build on Communicative Learning
> Structure Better Prompts
> Leverage AI In Marketing & Media
> Agile AI Case Studies

4:30 – 5:00 PM Course Closure 
> Content Review
> Open Q&A
> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

AI Application In Agile 
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 

12:00 - 1:00 PM

Morning Break 

Lunch
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About The Agile Leadership Summit

To maximize the effectiveness of Agile 
implementations, it is essential to secure robust 
support and trust from leadership and 
management. Executives are instrumental in 
eliminating barriers, empowering teams, and 
fostering a culture of motivation and inspiration 
throughout the organization, ultimately 
enhancing service delivery to end consumers. 
Achieving this requires a shared understanding 
among executives and across teams. This forum 
is designed to lay a foundational understanding 
of Agile methodologies, encompassing both 
principles and practices, which will be adopted 
by their teams. Through this initiative, 
management will gain insights into expectations 
and learn the most effective methods to support 
their teams in the Agile journey.

This Summit is tailored to cater to three 
distinct audience segments, with each 
segment receiving a schedule designed to 
comprehensively cover topics specifically 
relevant to their respective interests & needs: 

90 Minutes: Designed for up to five CXO 
Executives who are hoping to understand all 
of the essentials behind leading an agile 
organization. (Compare to CAL-E) 

Half Day: Curated for up to 20 leaders, we 
create awareness about the changing 
dynamics in today’s world of work & equip 
leaders with the practices they need to lead 
their teams. (Compare to CAL-T) 

Full Day: Designed to give up to 20 leaders 
full guidance on Agile leadership with 
relevant exercises and examples. (Compare 
to CAL-O)  

90 Minutes Agenda Item Details 

30 Minutes What Do I Need To Know 
About Agile? 

> The Agile Landscape
> Agile Learning Outcomes
> Importance of Limiting WIP

30 Minutes How Do We Get Started? 

> Getting Started Correclty
> The Agile 12 Step Program
> Data Driven Proof
> Outcome Over Output
> Agile Leadership Alignment

30 Minutes 
How Do We Responsibly 
Scale Agile? 

> 3 Keys to Prepare to Scale
> Leadership Responsibilities
> Executive Agility Focus
> Becoming an Agile Leader
> Open Q&A - Closing

Half Day 

One Hour Agile Approaches & VUCA

> Define VUCA
> Leadership Behaviors
> Cross-Functional Teams
> Organizational Culture
> Leading Without Bias
> Understanding Empiricism

One Hour Leading High 
Performing Teams

> High Performing Team Characteristics
> Team Engagement
> Servant Leadership
> Accountability Culture

One Hour Collaboration For 
Multiple Teams

> Scaling Challenges
> Trust & Collaboration
> Team Metrics

One Hour Influence As A Leader > Coaching & Influencing
> Open Q&A - Closing

8:30– 10:00 AM The Context For Agile

> Economic & Market Factors
> Fixed vs Growth Mindset
> The Agile Landscape
> Understanding WIP Limits
> Organizational Vision & Strategy

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Agile Overview

> The Agile Manifesto
> High Performing Teams
> Empirical Process Control
> Agile Methods Defied
> The Agile 12 Step Program

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Leadership In An 
Agile Context

> Servant Leadership
> The Power of The Story
> Leadership Values
> Structure Of An Organization
> Leadership & Governance Policies
> Agile Leadership Case Study

3:30 – 5:00 PM Course Closure 
> Leadership Facilitation Toolkit
> Understanding Communication
> Reading List
> Final Thoughts

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

Agile Leadership Summit
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 

Full Day 
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About The Certified ScrumMaster Workshop This 
workshop is unlike any other you’ve attended. It 
goes beyond theory, offering practical insights 
and solutions to real-world challenges. Here’s 
what makes it stand out:

Practical, Problem-Solving Focus:
While the class is grounded in the Scrum 
Framework and Agile concepts, the focus extends 
far beyond textbook theory. We dive deep into 
solving the pressing problems and challenges 
participants face, making the learning experience 
directly applicable to your work.

More Than Just Test Preparation:
If your sole goal is to pass the certification test, 
this class isn’t for you. While our students 
consistently achieve some of the highest average 
test scores among all trainers, our primary 
objective is to deliver meaningful, actionable 
knowledge that transforms how you work—not 
just help you pass a test.

Scrum for All Industries:
Scrum is no longer confined to software 
development or an all-or-nothing approach. This 
class highlights real-world examples of how 
organizations—ranging from startups to 
enterprises—have successfully adopted Scrum to 
drive dramatic incremental improvements across 
various industries.

Class Logistics: 

〉Eligibility To Take Scrum Alliance
 Online Practice Test and Test 

〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership 
〉Reference Workbook Included
〉Qualify for Level 2 A-CSM Certification

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Agile Mindset 

> Define Lean, Agile, & Scrum
> The Agile Manifesto
> Waterfall vs. Agile
> The Five Scrum Values
> The Agile Landscape

10:15 – 12:00 PM Agile Soft Skills

> Psychological Safety
> Radical Candor
> The REAL Three Questions
> The Agile 12 Step Program
> Do We Scrum Yet?

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Roles & Accountabilities 

> Roles Overview
> Executives & Leaders
> The Product Owner Role
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Understanding Scrum Teams

2:30 – 3:00 PM The ScrumMaster Role
> ScrumMaster & The Team
> ScrumMaster & The Organization
> ScrumMaster In The Real World
> ScrumMaster Skills & Attributes

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Scrum Execution 

> Day One Overview
> The 59 Minute Scrum
> Complete Agile Planning
> The Agile Daily Standup
> Morning Reflection

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Scrum Ceremonies, 
Estimating, & Forecasting 

> Sprint Planning
> The Daily Scrum
> Sprint Review & Retrospective
> Story Points & Estimation
> Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Definition of Done
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified ScrumMaster
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 
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About The A-CSM Workshop
As a Certified ScrumMaster® (CSM®), you’ve 
gained foundational knowledge of Scrum values, 
practices, and applications, positioning you to 
bring expertise and insights beyond traditional 
project management. However, becoming Agile 
is a lifelong journey. Successfully integrating 
Scrum values and Agile principles into your 
professional environment requires diligence, 
patience, and a steadfast commitment to 
continuous improvement.

The next step in your journey is earning the 
Advanced Certified ScrumMaster™ (A-CSM™) 
certification from Scrum Alliance®. This advanced 
program is designed for CSMs with one or more 
years of experience in the role, offering deeper 
insights and enhanced skills to elevate your 
impact.

Take the next step to refine your expertise, 
expand your capabilities, and solidify your path 
as an Agile leader.

Class Logistics:

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Agile & Scrum Overview 

> Presence In Scrum
> The Agile Umbrella
> History of Agile
> The Agile Manifesto
> The Agile Landscape

10:15 – 12:00 PM Agile Facilitation & Coaching

> Divergent vs Convergent Thinking
> Listening Techniques
> Coaching Stance
> Coaching Techniques
> AgileDad University Access

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Roles & Accountabilities 

> Teams vs Working Groups
> Team Technical Practices
> The Product Owner Role
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Definition of Done

2:30 – 3:00 PM The ScrumMaster Role
> ScrumMaster & The Team
> ScrumMaster & The Organization
> ScrumMaster In The Real World
> ScrumMaster Skills & Attributes

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Extended Agile Framework 

> Day One Overview
> Vision & Strategy
> The Agile Press Release
> The Agile Daily Standup
> The Agile Roadmap

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Scrum Ceremonies, 
Estimating, & Forecasting 

> Sprint Planning
> The Daily Scrum
> Sprint Review & Retrospective
> Story Points & Estimation
> Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Resolving Impediments
> Scaling Scrum & Agile
> Personal & Professional Development
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advanced Certified ScrumMaster
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

LEVEL ONE CSM & ONE YEAR 
WORK EXPERIENCE REQUIRED 

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 
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〉Eligibility To Take Scrum Alliance
 Online Practice Test and Test 

〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership 
〉Reference Workbook Included
〉Qualify for Level 3 CSP-SM Certification



About The CSPO Workshop

This workshop offers a truly unique learning 
experience, setting it apart from any other 
training you’ve attended. Here’s why:

Practical, Real-World Focus:
While rooted in the Scrum Framework and Agile 
concepts, this workshop goes beyond theory. We 
take a hands-on approach to address real-world 
challenges, helping participants solve pressing 
issues they encounter in their roles.

More Than Just Certification:
If your only goal is to pass the certification test, 
this is not the class for you. While our students 
consistently achieve top-tier test scores, our 
primary focus is on providing knowledge and 
skills that bring meaningful change to your work 
and organization.

Scrum Beyond Software:
Scrum is no longer confined to software 
development or an all-or-nothing approach. This 
class showcases real-world examples of how 
organizations—from startups to enterprises—
have adopted Scrum to achieve dramatic 
incremental improvements across various 
industries.

 Class Logistics: 

〉Eligibility To Take Scrum Alliance
 Online Practice Test and Test 

〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

Two Year Scrum Alliance Membership 
Reference Workbook Included

〉Qualify for Level 2 A-CSPO Certification

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Product Owner Role 

> Product Owner Anti-Patterns
> Product Owner Skills /Qualities/ Attributes
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> The Product Owner Conundrum

10:15 – 12:00 PM Working With Stakeholders

> Defining Stakeholder Groups
> Decision Making Approaches
> Facilitator Defined
> Coming To Consensus
> Product Owner 

Collaboration12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Product Strategy

> Vision & Strategy
> ART Of The Agile Press Release
> Agile Estimation
> Roadmapping & Rapid Release Planning
> Determining Velocity
> Initial Estimates From The PO/TA

2:30 – 3:00 PM The Agile Meetings Playbook
> Total Meeting Overview
> Product Owner As a Facilitator
> Meeting Optimization
> Calling In The RATS

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM 
Customer Research & 
Product Discovery 

> Understanding Roles & Personas
> Product Discovery Techniques
> Product & Feature Ideas
> Product Discovery
> Communicating Ideas

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Testing Product 
Assumptions 

> Sprint Review Meeting
> Advanced Product Discovery
> Assumption vs Hypothesis
> Outcome Over Output
> Defining Value

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Backlog Refinement
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified Scrum Product Owner
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 
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About The A-CSPO Workshop
As a Certified Scrum Product Owner® (CSPO®), 
you’ve gained the skills to maximize business 
value and optimize the Product Backlog, 
ensuring you deliver the best possible outcomes 
to satisfy key stakeholders.

The next step in your Agile journey is earning 
the Advanced Certified Scrum Product Owner® 
(A-CSPO®) certification. This advanced course 
builds on your foundational knowledge, 
equipping you with deeper insights and 
enhanced techniques to excel as a Product 
Owner.

You can enroll in the A-CSPO course at any time 
after completing your CSPO certification. To 
receive your A-CSPO certification, you’ll need at 
least 12 months of Product Owner experience 
logged in your Scrum Alliance profile.

 Class Logistics: 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Product Owner Role 

10:15 – 12:00 PM Product Owner Facilitation

> Divergent vs Convergent Thinking
> Listening Techniques
> Coming To Consensus
> Defining Key Terms
> Complete Agile Planning

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Working With Teams 

> 7 Deadly Sins of Technical Debt
> The Agile Umbrella
> Technical Practices
> Product Owner With Multiple Teams
> Feature Vs. Component Teams
> Managing Dependencies

2:30 – 3:00 PM Agility Understood
> Extreme Programming
> Dynamic Systems Development Method
> Feature Driven Development
> Lean & Kanban

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Scaling Agile 

> Scaled Agile Framework
> Large Scale Scrum
> Scrum At Scale
> Enterprise Scrum
> Disciplined Agile Delivery

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Developing Practical 
Product Strategies 

> The ART of The Agile Press Release
> Business Model, Value Proposition Canvas
> Lean Canvas
> Story Points & Estimation
> Roadmapping & Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Customer Research & 
Product Discovery 

> Product Discovery Techniques
> User Story Mapping
> Cognitive Bias
> Assumption vs Hypothesis
> Outcome Over Output
> Defining Value

3:30 – 5:00 PM Course Closure 
> Enhanced Backlog Creation
> Advanced Product Backlog Refinement
> Personal & Professional Development
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advanced Certified Scrum Product Owner
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

LEVEL ONE CSPO & ONE YEAR 
WORK EXPERIENCE REQUIRED 

Are you ready to book this as a 
private course for your group? 

Contact us today to schedule 
training and coaching! 

> Product Owner Anti-Patterns
> Product Owner Skills /Qualities/ Attributes
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Understanding Stakeholders & Personas
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〉Eligibility To Take Scrum Alliance
 Online Practice Test and Test 

〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership 
〉Reference Workbook Included
〉Qualify for Level 3 CSP-PO Certification



About The Certified Facilitator Workshop 
Facilitation is the cornerstone of effective 
collaboration, decision-making, and creativity 
within teams. The Certified Agile Facilitator (CAF) 
course is designed for individuals seeking to 
deepen their facilitation mindset and skills while 
learning from experienced Agile practitioners.

This workshop provides hands-on training to 
develop the expertise needed to guide teams 
toward meaningful outcomes. It’s an essential 
step for those aspiring to become Certified Agile 
Coaches, as facilitation is a critical tool in any 
coach's toolkit.  

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Setting The Stage 

10:15 – 12:00 PM 
Understanding Group 
Context & Needs

> Gaining An Understanding
> The Four Magic Words
> Psychological Safety
> Ethical Facilitation
> Facilitation Preparation Checklists

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Orientation of a Facilitator

> Facilitator Orientation Defined
> Group Decision Making
> Listening Techniques
> Delivering & Receiving Feedback
> Voice of The Group
> Models For Emotional Intelligence

2:30 – 3:00 PM Facilitating Through Conflict
> Defining Conflict

Hidden Benefits of Conflict
> Five Tips For Maintaining Positivity
> Conflict Resolution

3:00 – 4:00 PM Forwarding The Action
> The Decision Is NOT The End
> Taking Decision Actions Forward
> Walk The Walk

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Facilitation Review

> Personal Inspection & Adaptation
> Event Inspection & Adaptation
> Co-Facilitation - Fusion
> Facilitation Case Studies
> Cohesive Facilitation

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Facilitation Practice

> Introduction & Brainstorming
> Strengths & Techniques
> Role Play & Feedback
> Session Fine Tuning
> Wrap-Up And Reflection

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Facilitation Practice 
Continued

> Facilitation Practice - Preparation
> Assemble a Facilitation Plan
> Facilitation Practice - Demos
> Facilitation Practice - Feedback
> Discover Three improvements
> Agile Does Require Facilitation

3:30 – 5:00 PM Course Closure 

>
>> The Agile 12 Step Program 
> Deepening Your Facilitation Skills
> Podcast & Additional Resources
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified Agile Facilitator
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

 Class Logistics: 

〉AgileDad University Membership 
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉2-Year Scrum Alliance Membership
〉Preparation for Agile Coach Certs

Are you ready to book this as a 
private course for your group? 

Contact us today to schedule 
training and coaching! 

> Facilitation Defined
> Facilitation Is A Mindset
> The Facilitation Arch
> Why Facilitation?
> Facilitation Is a Different Coaching Stance
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Agile Coaching Skills

Learn the advanced coaching, mentoring, and 
leadership skills agile coaches need to drive high-
performing teams and deliver results. You'll learn by 
doing with specific examples and guidance in this 
highly interactive course.

Take key coaching skills from conceptual to practical 
in this scenario-based course. Agile Coaching Skills 
will introduce you to the "what" and "how" of 
today's most in-demand coaching skills. 

Introduction to Agile Coaching
Becoming an Agile Coach
Agile Coaching Skills
Coaching for Change: Making Agility Work

We recommend taking them in that order, although 
you can pick and choose from the courses that 
match your professional goals.

 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Facilitation Skills

Teaching Skills

Morning Break

Mentoring Skills

Advising Skills

Leading Skills

Pre-Lunch Recap 

Lunch

Coaching Skills

Agile Coaching
Skills Scenario

Afternoon Break

Building an AI-Enabled 
Product Practice

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile Coaching Skills
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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4 Hours



Agile Essentials

Upskill your employees or boost your resume with 
essential agile skills that support faster time to 
market, improved engagement and alignment, and 
adaptability that allows you to outpace the 
competition.

Build your core knowledge by understanding exactly 
what agility is and under what circumstances it can 
support organizational strategy and goals. Whether 
you're leading your company to deliver more value 
with enhanced adaptability or working as a member 
of a team, Agile Essentials equips you with 
everything you need to know to execute agile 
practices in support of your objectives.

 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Advancing & Scaling Agile

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 4 Hours

Welcome & Agenda 

What Is Agile

The Agile Team

Break 1

My Performance On A Team

Working On An Agile Team

Agile Practices

Agile Evolution

Agile Beyond Software

Agile Application Diversity

Break 2

Exploring The 
Agile Landscape

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile Essentials
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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Agile In Sales

Master the agile skills to excel in today’s competitive 
sales landscape, whether you’re aiming to boost 
personal performance or lead a sales team to 
consistently exceed targets.

Learn how to boost any sales team's agility so you 
can deliver value to customers faster, rapidly adapt 
strategies amid change, and stay ahead of the 
competition. You'll earn a microcredential to 
demonstrate your expertise.

You'll learn what agility in sales looks like, why it's 
crucial for success, and how to build or be a 
productive member of a highly effective agile sales 
team.

 Class Logistics: 
〉Scrum Alliance Micro-Credential
〉1 Day Online or In-Person Workshop 
〉Class Eligible For 8 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Advancing & Scaling Agile

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Foundations

Methods & Models

Morning Break

Mentoring Skills

Advising Skills

Leading Skills

Pre-Lunch Recap 

Coaching Skills

Agile Coaching
Skills Scenario

Afternoon Break

Building an AI-Enabled 
Product Practice

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile In Sales
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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Agile OKRs

Upskill teams to transform goals into game-
changing results. The Agile OKRs course equips your 
teams to align day-to-day operations with top 
priorities.

Create alignment and engagement around 
measurable, ambitious goals to advance strategic 
priorities and realize your vision.

In this course, you'll discover why objectives and key 
results are so effective and how they allow agile 
teams to measure progress toward goals while 
preserving their ability to pivot in unpredictable, 
changing environments.

Take this course as an individual to boost your 
resume and skill set. Or upskill your teams to use 
OKRs effectively for strategic planning.

〉
〉Prepare for Advancing & Scaling Agile

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Goal-Setting Fundamentals

Strategic Planning

Morning Break

Strategic Alignment

Objectives And Key Results

OKRs In Scrum

OKR Anti-Patterns

OKR Practice

OKR Alignment

Afternoon Break

OKRs And AI

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile OKRs
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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4 Hours

 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included



AI For Product Owners

From strategic planning to backlog management, AI 
has the power to transform your product 
management responsibilities. Find out how to 
leverage AI to streamline everything you do and 
earn a microcredential to showcase your skills.

Learn how to use GenAI and AI-integrated tools to 
enhance product management responsibilities, 
including drafting product requirements and 
supporting your team's collaboration.

This course guides you through everything you need 
to know about AI in the hands of a modern product 
owner (or product manager, strategist, etc.). Plus, at 
the end of the course, you'll put what you've learned 
into action in a prompt engineering lab. Test out 
your new skills on real-world scenarios that product 
owners face.

 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for AI Application In Agile

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Responsible Human &
AI Collaboration

Everyday AI Tools
For Product Owners

Morning Break

AI For Product Requirements

AI For Product User Stories

AI For Agile Teams

LLM Preparation 

AI For Processes

Prompt Engineering Lab

Afternoon Break

Prompt Refinement 
and Review

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

AI For Product Owners
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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4 Hours



AI For Scrum Masters

Learn how to engineer GenAI prompts, streamline 
workflows, and leverage AI for any team. In AI for 
Scrum Masters, discover how to welcome AI to your 
agile team while showcasing your knowledge with 
an in-demand microcredential.

With the right approach and expertise, you can 
seamlessly add AI to your team. AI can function as 
an agile co-pilot, operating effortlessly alongside 
team members to increase productivity, save time, 
and differentiate you as an AI-capable professional.

AI for Scrum Masters provides ready-to-use 
templates and tactics that are applicable across 
roles, including scrum teams, project managers, 
team leaders, and product managers.

Learn all of the ways you can integrate AI to assist 
with managing timelines, predicting risks, identifying 
metrics for team performance, and much more.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Morning Break

AI Powered 
Communication 
& Collaboration

Data Driven 
Team Management

The AI Scrum Master

LLM Preparation

Afternoon Break

Prompt Refinement 
and Review

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

AI For Scrum Masters
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for AI Application In Agile

Responsible Human &
AI Collaboration

Everyday AI Tools
For Scrum Teams

4 Hours

AI For Processes

Prompt Engineering Lab



Becoming An Agile Coach

As an agile coach, you'll adopt many stances 
depending on the situation. In this context, a 
coaching "stance" is the position you take—whether 
facilitating, teaching, leading, etc.—to guide people 
through the situation and toward improvement as 
an agile team. This course will take you through 
these stances so that you can coach teams and 
leaders through agile adoption roadblocks and 
hesitancy, everyday conflicts, and other 
organizational challenges on the road to continuous 
improvement.

Introduction to Agile Coaching
Becoming an Agile Coach
Agile Coaching Skills
Coaching for Change: Making Agility Work

We recommend taking them in that order, although 
you can pick and choose from the courses that 
match your professional goals.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item 

Welcome & Agenda 

Facilitation Skills

Teaching Skills

Morning Break

Mentoring Skills

Advising Skills

Leading Skills

Learning Recap 

Coaching Skills

Case Study

Afternoon Break

Training Recap and Q&A

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Becoming An Agile Coach
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

4 Hours



Conflict Management Skills

Learn how to manage and resolve conflict to build 
trust, improve communication, and support high-
performing teams. This course equips you with 
practical skills to turn workplace challenges into 
opportunities for collaboration and continuous growth.

Delve deeply into conflict dynamics, conflict resolution, 
psychological safety, and team cohesion with this 
course. With the in-demand skills of conflict 
management, you'll be prepared to foster continuous 
growth in teams and for yourself personally.

You'll learn through practical exercises and story-based 
scenarios while having the opportunity to engage and 
share with your fellow students.

Not only will you be prepared to guide teams through 
conflicts after this class, you'll also be equipped to 
navigate personal conflicts that arise.

 Class Logistics: 
〉Scrum Alliance Micro-Credential
〉1 Day Online or In-Person Workshop 
〉Class Eligible For 8 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 8 Hours

Welcome & Agenda 

Preparing To Tackle Conflict

Understanding Conflict

Morning Break

De-escalating Team Tensions

Creating a Strategy To
Master Conflict Management

Conflict Triggers

Pre-Lunch Recap 

Lunch

Honing De-escalation 
Techniques

Importance of 
Psychological Safety

Afternoon Break

Practice Scenarios

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Conflict Management Skills
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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Get Started With AI Prompt Engineering

Prompt engineering is the foundation of effective AI 
use. This course demystifies how prompts work and 
shows you how to design them for stronger, more 
consistent outcomes.

You'll start by exploring how AI understands and 
responds to prompts, then move into practical 
techniques for refining and adapting your inputs for 
specific goals.

Prompt engineering lab: Once you've learned 
prompting techniques and frameworks, put your 
knowledge to the test in the prompting lab! In this 
section of the course, you'll use mock and real-life 
scenarios to apply what you've learned. 

By the end of this microcredential course, you'll 
know how to guide AI with clarity to get the most 
useful outcomes. Stand apart as a pro with AI savvy.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

AI Exploration

Practical Techniques & 
Adapting Inputs

Prompt Engineering Labs

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Get Started With AI Prompt Engineering
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.25 Day Online or In-Person Workshop 
〉Class Eligible For 2 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

2 Hours



Introduction to Agile Coaching

From facilitation to leadership, learn the many skills 
and competencies essential to agile coaching and 
set a course for professional growth.

Take key coaching skills from conceptual to practical 
in this scenario-based course. Introduction To Agile 
Coaching will introduce you to the "what" and "how" 
of today's most in-demand coaching skills. 

Introduction to Agile Coaching
Becoming an Agile Coach
Agile Coaching Skills
Coaching for Change: Making Agility Work

We recommend taking them in that order, although 
you can pick and choose from the courses that 
match your professional goals.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

What Is Agile Coaching

The Agile Coach

Break 1

Navigating The Agile 
Coaching Growth Wheel

The Coaching Presence

Self-Mastery

Ethical Considerations

Break 2

Coaching Essentials

Case Studies

Break 3

AI Impact On Coaching

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Introduction to Agile Coaching
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

4 Hours



Scrum Essentials

After completing this course, you'll be equipped to 
improve your practice of scrum in any role. The 
objectives of Scrum Essentials include:

o Defining "agility" 

o How agility differs from traditional project 
management

o Who are the scrum team members?

o The scrum events and their purpose

o Qualities and strategies of successful scrum teams

o When to use scrum

o Tips for overcoming common challenges when 
you adopt scrum

 Class Logistics: 
〉Scrum Alliance Micro-Credential 
〉.5 Day Online or In-Person Workshop 
〉Class Eligible For 4 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included

〉Prepare for Coaching For Change

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item 

Welcome & Agenda 

Introduction to Agile & Scrum

The Scrum Framework

Break 1

The Scrum Team - 
Foundation For Success

Scrum Events In Action

Scrum For 
Product Development

Pre-Break Recap 

Break 2

Scrum In a 
Non-Scrum Environment  

Scenario Simulation

Break 3

Navigating The 
Scrum Events

Course Closure 

LearnMore@AgileDad.Com 
866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Scrum Essentials
Scrum Alliance Microcredential
Instructor: V. Lee Henson CST 
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4 Hours



Project Management Professional - Test Prep

The Project Management Professional (PMP) 
certification recognizes individuals who excel in 
managing people, processes, and business 
priorities across professional projects. Created 
by the Project Management Institute (PMI)—
the world’s leading authority on project 
management—the PMP demonstrates a 
project manager’s proven leadership experience 
and expertise, regardless of their preferred way 
of working.

To earn the PMP certification, candidates must 
meet specific eligibility requirements and pass a 
rigorous 180-question exam. Designed by 
project leaders for project leaders, the exam is 
rooted in real-life project management 
scenarios, ensuring the knowledge gained is 
practical and applicable.

No prior knowledge or experience is 
required to attend PMP Certification 
Training. 

To qualify for the PMP exam your should 
either have:

High school diploma and Minimum 60 
months/5 years experience leading and 
managing projects within the past eight 
years.

35 hours of project management 
education/training. 

You can also meet this requirement with a 
Bachelor's degree or higher and 36 
months/3 years experience leading and 
managing projects within the past eight 
years.

35 hours of project management 
education/training.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item Details 

Welcome & Agenda
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

Course Foundations

> Understand Essential Terms
> Explore Various Models
> PMP Cert Explained
> Qualifications Explained
> Materials Overview

Business Environment
> Strategic Alignment
> Project Benefits & Value
> Org Culture & Change Management
> Project Governance & Compliance
> Business Case Study

Start The Project

> Identify & Engage Stakeholders
> Form The Team
> Build Shared Understanding
> Determine Project Approach
> Business Case Study
> Help Me Understand

Plan The Project
> Planning Projects
> Schedule & Sxcope
> Resources & Budget
> Quality & Risks

Lead The Project Team > Create a Collaborative Environment
> Support & Empower The Team
> Manage Conflict

Project Team Performance > Implement Ongoing Improvements
> Manage Project Changes

Closing The Project / Phase
> Project or Phase Closure
> Benefits Realization
> Knowledge Transfer
> Business Case Study
> Team Sign-Off

Preparing For the PMP Exam
> Formulas To Memorize
> Leverage The PMBOK
> Best Study Practices
> Prep For Test Day
> Additional Details

Practice Test and 
Additional Resources

> Access To Practice Test
> Access To Agile Resources
> Access To The BEST Books
> List of Additional Study Guides
> Helpful Websites
> What To Expect

Course Closure 
> Content Review
> Open Q&A
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

Project Management Professional - PMP
PMI Certification Test Preparation
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COURSE CONTENT AVAILABLE WHEN YOU NEED IT

OBSERVE AND REPLICATE REPEATABLE RESULTS 

EDUCATE AT A COMFORTABLE KNOWLEDGE LEVEL

LET AGILEDAD CREATE CUSTOM CURRICULUM & 
COURSEWARE FOR YOUR ORGANIZATION 

AgileDad Creates curriculum designed to help your organization be successful. Our solutions 
can be purchased outright and carry your organization's logo, or can be leased on a per use 

basis. Please contact LearnMore@AgileDad.Com for more information and pricing. 

AgileDad also offers a variety of E-Learning modules! These modules 
are available by subscription only. Contact LearnMore@AgileDad.Com 
for details and pricing. 

• Allow your company to learn from wherever they are.
• Always have the most current Agile teachings at your fingertips.
• Affordable subscription model makes it easy and effective for most organizations.
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• AGILE FOR NON-COLOCATED TEAMS
• BUSINESS ANALASYS & CREATION
• CONTRACTS FOR AGILE PROJECTS
• DEVOPS IN AN AGILE WORKSPACE
• EDUCATION USING AGILE METHODS
• FUNDING MODELS FOR AGILE
• GETTING THINGS DONE WITH AGILE
• HUMAN CENTERED WORKSPACES
• IDENTIFYING & MANAGING TECH DEBT
• JUMPSTART YOUR AGILE PROJECT
• KANBAN & SCRUMBAN FOR TEAMS
• LEAN DESIGN SYSTEMS THINKING
• MAP - BUILDING THE RIGHT THING

Raising 
TheBar!

800+
successful implementations 

$2.8M
avg. cost savings per year

350%
avg. increase in productivity

100%
organizational success

Back in 2007, we were working for an organization that tried to help businesses 
better understand and practice greater agility. Through this work we made a few key 
discoveries. Businesses were fixated on taking what they were currently doing and 
optimizing it instead of seeking out a new and better way to execute. Even if they did 
seek to change, they would often be so embedded in their failing process that they 
would try the new framework for a very limited time and often fall back into their 
previous failing practices. Many of the big consulting firms were enabling this 
behavior by placing coaches into the organization full time to try and manipulate 
their current failing processes in an effort to get the paycheck and not rock the boat.  

This is when I said to myself somebody needs to do something about this. The truth 
needs to be spoken. This is when we met with our very first Fortune 100 CEO where 
after we presented to him he said, “You do realize they are all going to hate you. It is 
not because you are wrong or doing anything that should not be done. It is more 
because at this stage most companies out there are like angry teenagers. They ask 
for the advice, listen to you, and stand strong to tell you that you got it all wrong. 
They are not ready to receive the sage advice you have given them and will often try 
to do the exact opposite to prove a point. I expect you to come in and plant a seed. 
Let us water and nurture it for a time. We will then call you in roughly six months and 
let you know that you were right all along and we are now ready to accept your help 
and coaching.” 

The pattern above has manifest itself at least a hundred times and has often 
repeated itself for greatest emphasis. It became a self-fulfilling prophecy. We would 
enter an organization, present observations, get beat up pretty badly, get thrown out, 
and get invited back to boil the now more polluted ocean months or even in a few 
cases years later. Our goal for AgileDad was to create a company where we keep the 
client list small at any given time, provide world class leadership/team-based training 
& coaching for companies of any size, and be a catalyst for good in the world while 
simplifying and humanizing work. We have since invited many Agile coaches and 
trainers both male and female to join us on this amazing crusade to promote a 
healthy more pragmatic approach to implementing Agile. 

The name AgileDad is a great descriptor of what we do. We are not always 
conventional. We have built an amazing diverse team of individuals who each are 
contributors to the fabric of our story. We are AgileDad

AgileDad Supports Education at All Levels
• AgileDad is proud to partner with major universities to provide world class

business and project management curriculum.
• AgileDad has sponsored events to help educators at all levels achieve Agile &

Scrum Certifications to help them be successful in the classroom.
• To learn more, please contact us at LearnMore@AgileDad.Com

• NON-SOFTWARE AGILE IMPLEMENTATION
• ORGANIZATIONAL AGILE TRANSFORMATION
• PROGRAM & PORTFLIO MANAGEMENT
• QUALITY ASSURANCE & AGILE
• RAPID RELEASE PLANNING & AGILE
• SCALING AGILE & STRATEGY
• TEST AUTOMATION & AGILE
• USER EXPERIENCE (UX) & AGILE
• VALUE DRIVEN DESIGN & FOCUS
• WORK IN PROGRESS (WIP) LIMITS
• XP & AGILE INTEGRATED
• YARDSTICKK & OTHER AGILE METRICS
• ZESTFUL AGILE IMPLEMENTATIONS

The AgileDad Name

AGILEDAD MODULES - A-Z AGILE FOCUS
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Can
AgileDad 
Coaching Help 
Your Company?
The AgileDad Coaching approach is different 
and truly unlocks and maximizes your 
potential for Agile Implementation success!

For years many organizations have offered the same type 
and model for Agile Coaching. Your company spends a 
large part of its' budget on bringing in a company that 
plants one coach on the ground and provides you with 
round the clock coaching at a standardized rate whether 
you need that coach there or not regardless of their 
specialty. This is a non-working solution that we have 
found a remedy for. 

We start with an initial assessment of the Agile teams and 
contributors, long-term targets will be set with regard to 
your company’s vision and implementation plan for Agile. 
This includes short-term and long-term plans to help 
teams, ScrumMasters, Product Owners and leaders be 
highly effective by utilizing the AgileDad 12 step coaching 
model. Coaching hours may be used for planning, resolving 
impediments, backlog grooming, mentoring, or anything 
that helps your organization see Agile success. We 
systemically help with the cultural and organizational 
changes needed, process improvement and sustainability 
of those changes . Coaching hours are sold as a bucket of 
hours that never expire so the right coach can help you to 
get Agile started or refined within your organization. The 
goal of the Agile Coach in your organizations to work with 
the organization to develop an Agile Center for Excellence 
for long-term sustainability internally instead of long-term 
dependency on coaching and consulting services. 

Coaching hours are billed at a flat rate and you have the opportunity to utilize that time based on the level of coach needed in 
order to facilitate the type of work that needs to be done. In order to maintain scheduling and coaches sanity, we do enforce 
minimum on-site time-lines that are short in nature and do allow for hours to be used remotely when applicable. This unique 
approach has yielded some amazing results. Do not take our word for it. Here is what a few of our clients have had to say: 

""The great thing about having an AgileDad coach is being able to have an outside perspective to see what we can do to improve. It helps 
identify where are we a little bit off, what is working well and is really helping to improve where it makes sense. It's an investment and 
well worth it." "Some of the first guidance I heard was about team size and how getting to the right team size would improve how 
productive we were in addressing the right priority items. Doubling production by dividing just didn't make sense to me but after we 
got teams to the right size, there are many teams that are now reporting 3 to 4 times the improvement in throughput. It's 
amazing that such a simple concept has made profound impact for our company." "After training and some initial follow-up 
coaching sessions, the office is hyped on this applying-new-knowledge-to-processes, so hooray!""

How is AgileDad Coaching different from the rest? 

• AgileDad sells coaching as a bucket of hours that you can use as needed.
• The bucket of hours NEVER expire!
• All AgileDad Coaching is 100% guaranteed! We will enhance your process!
• AgileDad has Micro-Coaching - The FIRST & only try before you buy!
• MANY qualified references available upon request for your review.

LearnMore@AgileDad.Com
866-410-1616
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Best Training I have ever had! I am 
pleased to add Agile Scrum Master 
Certification to my portfolio 
(including Six Sigma Master Black 
Belt Certification), thanks to Lee's 
training and encouragement. Lee is 
very engaging and keeps the subject 
interesting! I highly recommend Lee 
to individuals and companies for his 
training and motivational 
presentations!

 Dino Marsili - Cisco 

I was privileged enough to be able to take 
CSPO and CSM workshops in 2017. The 
teaching style is hands on and practical. He 
has the ability to create balance between 
the training materials and real life 
application of the information. He is very 
engaging and keeps the students full 
attention and participation throughout both 
courses. He is down to earth and truly cares 
about the students that he is teaching. He 
wants all of his students to be successful in 
their aspirations and this was clear in how 
he lead and interacted with students from 
all walks of life. His class has been a catalyst 
to change for me and I will always 
appreciate learning from him. 
Keri Dunlap - Innovation - Worldpay

I recently completed the Scrum 
Certified Product Owner course under 
Lee's tutelage and realized that he's 
the single best instructor I've had 
during my professional career. Lee has 
the unique ability to transform the 
complex into the manageable and the 
challenging into understandable, all 
while promoting an enjoyable learning 
atmosphere. He can be an invaluable 
human resource for anyone looking to 
fully understand Scrum and take their 
career to the next level.

Chris Errington - Nielsen Company

The AgileDad CSM course was 
undoubtedly one of the most 
interesting and beneficial courses I 
have taken. Not only did the course 
provide great information, but also a 
very fun learning environment that 
made it easy to sit through a two day 
course (which is usually not the case!). 
I would absolutely recommend the 
AgileDad courses to anyone 
interested in learning about Scrum.

Carley Donovan - Salesforce

I have had the wonderful opportunity to 
participate in Certified Scrum Master 
training. The training itself was unlike any 
training I have participated in! Aside from 
being incredibly thorough as it pertained 
to the CSM discipline, it was engaging, 
entertaining and truly hands on. I 
definitely received more than I bargained 
for in a very positive way. The morning 
exercise on the first day created a 
positive synergy with the other 
participants that carried through the 
entire class. I highly recommend Agile 
training and any other Agile or Project 
Management classes in the future. 
Shauna Kay Harris - Delta Airlines

I had the pleasure of attending a Certified 
Scrum master course. I have thought 
technical subjects over the years and 
attended many training sessions and 
courses. This was without doubt one of the 
best i have participated in. He delivered the 
material in a entertaining way, anchored it 
to real world scenarios, explained complex 
areas from a multiple of view points. Was i 
able to pass the exam? Without a doubt, but 
that wasn't really the point for me. If you 
want to learn SCRUM or solidify and 
improve what you do with Agile already 
then I encourage you to seek Lee's course 
out and sign up. 

Mat Young - Dell EMC
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